Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]


On May 16, 2012, at 4:02 AM, Stian Soiland-Reyes wrote:

> On Tue, May 15, 2012 at 1:37 PM, Timothy Lebo <> wrote:
>> "quoted" parallels "taken" conceptually.
> or "took", if your mind is implying an agent. In my mind, "quoted" is
> more like "cited", but then I'm not a native English speaker.

I think your "swapped" interpretation is reflected by:

:bible :wasCitedIn :hisSermon .

> We normally consider agents doing quoting than paragraphs.

:bible :wasCitedBy :priest .

Agents aren't involved in prov:wasQuotedFrom, it's between entities (big and small).

> Stian quoted the bible, and so the bible 'was quoted'. "Has this
> document been quoted anywhere?"

:bible :wasQuotedBy :priest .

These are reasonable questions to answer, but it is a "downstream" direction that is dissonant with the "upstream" (backward in time) direction that all of the other properties provide (used, wasGeneratedBy, etc).

>  The "From" is the spanner in the
> works, it tries to change the directionality, and I understand the
> phrase "was quoted from", but when you see it there in the RDF and
> it's not something as easy as a paragraph and a bible, but a blogpost
> and a tweet, then you can't really be sure.
>> And breaking the "wasDerivedFrom" pattern seems like a bad idea as we're trying to finish up with a more consistent model, not less.
> I agree to not fracture the model. I was just hoping for a small
> modification to clarify the direction, like "wasQuoteFrom". I think
> that is more important than if it is still a quote or not.



> -- 
> Stian Soiland-Reyes, myGrid team
> School of Computer Science
> The University of Manchester

Received on Wednesday, 16 May 2012 15:37:28 UTC