Re: PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

We started with wasQuoteOf
But moved away because not clear.


Professor Luc Moreau
Electronics and Computer Science
University of Southampton
Southampton SO17 1BJ
United Kingdom

On 19 Apr 2012, at 17:39, "Daniel Garijo" <<>> wrote:

Hi Luc,
the definition on DM is very clear to me.

What makes me feel a bit unconfortable is that while I can understand what is on the domain
and what is on the range on each of the other properties, for this one I think it is a bit confusing.
(When I say domain and range, I refer to what is being quoted (original) and what is the quote).

I have asked 3 colleagues in my lab to tell me what did they think they were the range and the domain
of the property with an example, (without looking at the definition of the DM). One of them agreed with the DM,
another one guessed wrong and the last one encouraged me to change the naming because "it made
no much sense" to him.

I'm not sure if users that assert scruffy provenance will come to the DM to read all the definitions,
and that is why to make sure this kind of things are very clear for everyone. Thus, I don't propose
to change the definitions, I just suggest to rename "wasQuotedFrom" to either:
"wasQuoteOf" or "hadQuoteFrom".


2012/4/19 Luc Moreau <<>>
Hi Daniel,

This is the current definition of quotation. Is there still a concern with it?


4.3.3 Quotation

A quotation is the repeat of (some or all of) an entity, such as text or image, by someone other than its original author.

Quotation is a particular case of derivation in which entity e2 is derived from an original entity e1 by copying, or "quoting", some or all of it. A quotation relation, written wasQuotedFrom(id,e2,e1,ag2,ag1,attrs) in PROV-N, has:

id: an optional identifier for the relation;
quote: an identifier (e2) for the entity that represents the quote (the partial copy);
original: an identifier (e1) for the original entity being quoted;
quoterAgent: an optional identifier (ag2) for the agent who performs the quote;
originalAgent: an optional identifier (ag1) for the agent to whom the original entity is attributed;
attributes: an optional set (attrs) of attribute-value pairs representing additional information about this relation.

On 04/19/2012 11:28 AM, Provenance Working Group Issue Tracker wrote:
PROV-ISSUE-352 (rename-WasQuotedFrom): A better name for wasQuotedFrom [prov-dm]

Raised by: Daniel Garijo
On product: prov-dm

Currently, the DM says:
A quotation record, written wasQuotedFrom(e2,e1,ag2,ag1,attrs) in PROV-ASN, contains:
    quote: an identifier e2, identifying an entity record that represents the quote;
    quoted: an identifier e1, identifying an entity record representing what is being quoted;

However, if we say that e2 wasQuotedFrom e1 it may look like entity e1 is the one quoting e2 (since we are saying that e2 was quoted).

I think it would be more clear if we rename the property with e2 wasQuoteOf e1, or e2 hadQuoteFrom e1.


Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487<tel:%2B44%2023%208059%204487>
University of Southampton          fax:   +44 23 8059 2865<tel:%2B44%2023%208059%202865>
Southampton SO17 1BJ               email:<>
United Kingdom           <>

Received on Thursday, 19 April 2012 16:53:36 UTC