W3C home > Mailing lists > Public > public-ontolex@w3.org > July 2013

SKOS compatibility

From: John McCrae <jmccrae@cit-ec.uni-bielefeld.de>
Date: Fri, 19 Jul 2013 17:25:47 +0200
Message-ID: <CAC5njqoQhAdBvSS4DXhONBhbSFLFU989xneYSv9SHGWboA=T+g@mail.gmail.com>
To: public-ontolex <public-ontolex@w3.org>
Hi all,

A couple of points I wanted to propose to enable the model to have a
clearer compatibility with SKOS and SKOS-XL.

Firstly, the use of rdfs:label on LexicalEntrys, is a technique that we
have used previously so that we do not need to create a form node for each
entry. E.g.,

:Shisa a ontolex:LexicalEntry ;
  rdfs:label "shisa"@eng .

Would be considered equivalent to

:Shisa a ontolex:LexicalEntry ;
  ontolex:lexicalForm [
    ontolex:writtenRep "shisa"@eng
  ] .

There are two other alternatives here, either we do not have any such
properties (specifying a form is then mandatory) or we introduce a new
property in the OntoLex namespace that has the role. Note, one of the key
issues here is that with OWL we cannot specify the equivalence between this
property and the lexicalForm o writtenRep chain, so I would prefer to
re-use rdfs:label, which has the correct semantics anyway

Secondly, we should be able to indicate which entries are the preferred,
alternative and deprecated lexicalizations of a given concept. For example,
we could look into introducing a property which starts in the ontology and
points to a lexical entry, e.g., something like this

:Scope a ontolex:LexicalEntry ;
  ontolex:sense [ ontolex:reference dbpedia:Scope_(Charity) ] .
:Spastics_society a ontolex:LexicalEntry ;
  ontolex:sense [ ontolex:reference dbpedia:Scope_(Charity) ] .

dbpedia:Scope_(Charity) ontolex:preferredEntry :Scope ;
  ontolex:hiddenEntry :Spastics_society .

As such, these properties would each be sub-properties of the inverse of

Do these two proposals seem reasonable?


PS SKOS recommend using hiddenLabel for spelling mistakes. I don't think we
should support this in the meaning of hiddenEntry instead with the idea
being that hidden terms are simply outdated (deprecatedEntry may be a
better name for the property if we do not wish to follow SKOS).
Received on Friday, 19 July 2013 15:26:19 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:36:33 UTC