W3C home > Mailing lists > Public > public-media-capture@w3.org > November 2012

Re: recording

From: Adam Bergkvist <adam.bergkvist@ericsson.com>
Date: Mon, 19 Nov 2012 12:02:16 +0100
Message-ID: <50AA11B8.3010402@ericsson.com>
To: "Sunyang (Eric)" <eric.sun@huawei.com>
CC: Jim Barnett <Jim.Barnett@genesyslab.com>, "public-media-capture@w3.org" <public-media-capture@w3.org>
On 2012-11-16 10:20, Sunyang (Eric) wrote:
>
>> -----Original Message-----
>> From: Adam Bergkvist [mailto:adam.bergkvist@ericsson.com]
>> Sent: Tuesday, November 13, 2012 8:32 PM
>> To: Jim Barnett
>> Cc: public-media-capture@w3.org
>> Subject: Re: recording
>>
[...]
>> I liked the old requestData() rather than getData(). If a method is
>> prefixed "get" it's tempting to read a return value.
>>
>
> Any difference? getData can return a BLOB object, requestData also do the same thing.

getData() can't return a Blob since the operations involved in preparing 
the return value could be time consuming and block the event loop too 
long. getData()/requestData() is more a request to fire the 
"dataavailable" event with new data as soon as possible. That's why I 
like the requestData() name better.

/Adam
Received on Monday, 19 November 2012 11:02:45 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:26:12 UTC