IndieUI Event Interfaces

Hi,
   The event interfaces are currently defined in a way that doesn't 
match the rest of the platform.

The UIRequestEvent defines an "eventType" attribute as an unsigned 
short, with various constants defined to identify the type.  The exact 
purpose of these constants is not clear as it does not match the way in 
which event types are indicated for other events.

The UIRequestEvent inherits from UIEvent, which in turn inherits from 
Event.  The Event interface defines a "type" attribute as a string. 
e.g. "click", "mouseover", etc.  This same type attribute should be used 
for these newly introduced events. e.g. "undorequest", "dismissrequest", 
etc.  The constants (UNDO, REDO, etc.) and the eventType attribute 
defined in the UIRequestEvent interface should be removed.

The names of the events defined in this specification should also match 
the conventions used for other events in the platform.  The names are 
case sensitive and should be defined in all lower case, rather than 
camel case (e.g. "undorequest" instead of "UndoRequest").

-- 
Lachlan Hunt - Opera Software
http://lachy.id.au/
http://www.opera.com/

Received on Monday, 5 November 2012 12:49:20 UTC