W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > September 2009

[Bug 7367] The HTMLEmbedElement interface needs to have the name and align DOM attributes as well. Web browsers do too.

From: <bugzilla@wiggum.w3.org>
Date: Sat, 19 Sep 2009 21:58:07 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1Mp7wV-00076c-Kw@wiggum.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=7367


Ian 'Hixie' Hickson <ian@hixie.ch> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME




--- Comment #1 from Ian 'Hixie' Hickson <ian@hixie.ch>  2009-09-19 21:58:07 ---
The spec defines how name="" and align="" affect <embed>, but it doesn't
encourage their use for that purpose, since they're redundant with id="" and
CSS.

I didn't list them in the "obsolete" section because they're conforming for
other reasons (all attributes on <embed> are), and I figured it'd be confusing
to list them there while they still didn't raise an error, and since <embed>
wasn't in HTML4 anyway, there wasn't any theoretical reason to include them.

So I'm not sure what to do here.


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Saturday, 19 September 2009 21:58:16 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 20:01:01 UTC