W3C home > Mailing lists > Public > public-fx@w3.org > January to March 2015

Re: [web-animations] AnimationPlayer.source

From: Shane Stephens <shans@google.com>
Date: Wed, 04 Feb 2015 01:20:22 +0000
Message-ID: <CAGTfzwR0r_S0Q1mn_o4gvWhKVN7Dn9zLCD-5iwpj+bEOyxto2w@mail.gmail.com>
To: Jonathan Watt <jwatt@jwatt.org>, public-fx@w3.org
On Wed Feb 04 2015 at 11:47:12 AM Jonathan Watt <jwatt@jwatt.org> wrote:

> I'm not sure. I guess it depends on what type of object the property would
> actually point to. I'd assume it wouldn't point directly to an element, so
> if
> the type of the objects is something like VideoAnimation, then it probably
> still
> would make sense. If the name of the type of object doesn't contain the
> word
> "animation", possibly it wouldn't.
>
> Is this something that is planned for a spec?
>

It's something we initially incorporated into the spec, but decided to
defer to a later level so that we could iterate faster.

Cheers,
    -Shane


>
> On 04/02/2015 00:35, Shane Stephens wrote:
> > Hi Jonathan,
> >
> > Thanks for your feedback.
> >
> > Would 'animation' still be appropriate if players can target
> non-animation
> > content (e.g. video or audio) in the future?
> >
> > Thanks,
> >      -Shane
> >
> > On Wed Feb 04 2015 at 11:28:56 AM Jonathan Watt <jwatt@jwatt.org
> > <mailto:jwatt@jwatt.org>> wrote:
> >
> >     Can the AnimationPlayer.source property *please* be renamed? The
> word "source"
> >     doesn't seem to make any sense, and would seem to imply it points to
> the element
> >     or something. It pointing to the Animation object was completely
> >     counterintuitive to me, since I'd think of the relationship being
> reversed. I.e.
> >     the AnimationPlayer controls the Animation, and in that way its
> actions "target"
> >     the Animation, which is the inverse direction of a source<->target
> relationship.
> >
> >     I'm not sure "target" is a good name though, since to the
> uninitiated on anyone
> >     not frequently dealing with animations scanning through code that
> again would
> >     likely look like it refers to the element. I'd suggest calling it
> "animation".
> >
>
>
Received on Wednesday, 4 February 2015 01:20:50 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:49:52 UTC