[web-animations] Should "offset" be considered good naming?

Hi list,

I'm forwarding some feedback submitted by Martin Heidegger as an issue to
 the web animations polyfill (

"offset" as used in web-animations to indicate that some animation should
be run at a time-offset is mixed with other properties like "left" or
"marginTop" etc. many of those properties indicate a geometric space in
which "offset" as a word also has a common meaning and is often used.

To make this clearer to the reader and easier to learn I am wondering if a
property like "timeOffset" might be better.

Thanks Martin! We'll consider your suggestion in our next spec meeting.

    -Shane Stephens

Received on Friday, 26 July 2013 10:46:39 UTC