Unfortunate choice of attribute name in XForms 1.1: xforms:submission/@target


It just occurred to me that the XForms 1.1 xforms:submission/@target  
attribute [1] is badly chosen.

The reason is that a "target", in HTML speak, specifies an optional  
target window or frame. This, in particular, applies to <a> and <form>  
in HTML. [2]

In the future, we may want to officially support such a concept of  
target window or frame in XForms. Purely out of familiarity with HTML,  
the name "target" would be an obvious choice. But if we use "target"  
now to specify the destination for data replacement, we won't be able  
to use that name.

(Note that in our implementation, we already support an extension  
attribute called xxforms:target on xforms:submission and xforms:load,  
which behaves like its HTML counterpart.)

For this reason I suggest that we change the name of this attribute in  
XForms 1.1. Suggestions are welcome, but "destination" could work.


[1] http://www.w3.org/TR/xforms11/#submit
[2] http://www.w3.org/TR/html401/present/frames.html#adef-target

Orbeon Forms - Web Forms for the Enterprise Done the Right Way

Received on Tuesday, 8 April 2008 00:30:43 UTC