Re: [Fwd: Binary proposal]

On 14 March 2013 11:05, Jirka Kosek wrote:
> On 13.3.2013 15:18, Christian Grün wrote:

>> - Most EXPath specs and vendor-specific modules avoid
>> redundancies in the prefixes and the function names.  This is
>> why I would suggest to remove the "binary-" string in some of
>> the function names and instead rename the prefix to "binary".
>> The resulting names could be called "binary:length",
>> "binary:or", etc.

> This looks tempting.  However my only concern is that if this
> binary module is adopted as built in for some future version of
> XPath/XQuery/XSLT then it would be more natural to allow to use
> functions without namespace prefixes.  By removing binary-
> prefix we will get naming clashes with several existing XPath
> functions.

  My bet is that if the module is adopted in F&O 3.1 or in XSLT
3.0, they will remain in their own namespace, like math:* and
map:* functions.  Even if it is not the case, as soon as the
namespace changes, the WG can change the local name as well, the
effect is the same: the name is not the same anymore.

  So I feel like the possibility of being adopted by F&O and/or
XSLT should not affect the naming conventions for the EXPath-
version of the module.  I personally like bin:length, bin:or,
bin:and, etc.


Florent Georges

Received on Thursday, 14 March 2013 16:24:42 UTC