Re: Vibrator API: extract from Navigator

> partial interface Vibration {

But now it's no longer a partial interface, right?

On Tue, Nov 8, 2011 at 6:23 AM, Anssi Kostiainen
<anssi.kostiainen@nokia.com> wrote:
> Hi,
>
> On 8.11.2011, at 10.37, ext Dave Raggett wrote:
>
>> On 07/11/11 21:44, Justin Lebar wrote:
>>>> Having a Vibrator interface, which then Gamepad and Navigator implement,
>>>> hence being reusable.
>>>>
>>>> So we then get navigator.vibrate() and gamepad.vibrate(). Same API, same
>>>> behavior.
>>
>> Isn't this just a matter of replacing "Navigator" below with a more appropriate name, e.g. "Vibrator" and then specifying that the navigator object implements the Vibrator interface, e.g. as navigator.vibrate(1000);
>>
>> partial interfaceNavigator  {
>>    void  vibrate  <http://dev.w3.org/2009/dap/vibration/#widl-Navigator-vibrate-void-long-time>  (optionallong  time);
>>    void  vibrate  <http://dev.w3.org/2009/dap/vibration/#widl-Navigator-vibrate-void-longArray-pattern>  (optionallong[]  pattern);
>> };
>
> Yes. Here's the new IDL which should address João's reusability concerns:
>
> Navigator implements Vibration;
>
> partial interface Vibration {
>    void vibrate (optional long time);
>    void vibrate (optional long[] pattern);
> };
>
> I updated the Editor's Draft accordingly. Let me know if there are any concerns with this change.
>
> -Anssi
>

Received on Wednesday, 9 November 2011 08:30:25 UTC