Callback naming

Hi,

in the interest of shorter names (and WebIDL that doesn't extend over to one's neighbour's screen), should we use "CB" as short for callback? PendingOperation could also be PendingOp. Such changes have minimal impact as no constructors exist for these anyway. It also avoids the xxxCallBack vs xxxCallback disparity.

E.g.:

PendingOperation captureDahut (in CaptureCallback successCallback, in optional ErrorCallback errorCallback);

replaced by 

PendingOp captureDahut (in CaptureCB successCB, in optional ErrorCB errorCB);

Thoughts?

-- 
Robin Berjon - http://berjon.com/

Received on Wednesday, 2 December 2009 11:15:39 UTC