Re: Specific proposals for ISSUE-1


I understand that this may be seen as a subtle distinction. I believe
we agree that we should at least be consistent with the use of "Class"
as in sh:scopeClass and sh:valueClass. You believe that most new SHACL
users will want to use sh:valueClass. We can even recommend its use.

We can describe sh:valueType as being defined for backward
compatibility with oslc:valueType. OSLC users will feel comfortable
with this term.

-- Arthur

On Tue, Jun 23, 2015 at 10:15 PM, Holger Knublauch
<> wrote:
> On 6/24/2015 10:50, Arthur Ryman wrote:
>> +1
>> However I suggest a name change.
>> Use sh:valueClass in Proposal 2. This consistent with sh:scopeClass in
>> Proposal 4.
>> Use sh:valueType in Proposal 3.
> My concern is how to explain this difference to users. This distinction is
> very subtle and many people will make mistakes unless we select very clear
> names. With valueClass and valueType I would myself be confused, because the
> choice feels arbitrary to me. I could live well with sh:valueClass replacing
> the current sh:valueType (also because it aligns well with sh:scopeClass).
> But then I think we need something more distinct for the case of direct
> rdf:type without subclasses. We can hopefully solve this quickly during the
> next meeting.
> Holger

Received on Wednesday, 24 June 2015 11:33:46 UTC