W3C home > Mailing lists > Public > public-cwm-bugs@w3.org > May 2004

diff.py not working

From: Henry Story <henry.story@bblfish.net>
Date: Fri, 7 May 2004 19:10:07 +0200
To: public-cwm-bugs@w3.org
Message-Id: <63BFCC5E-A049-11D8-BE2D-000A95D9FA7A@bblfish.net>
Hi, I was really interested to get diff.py to work.

Perhaps I am doing something wrong. But since I ran the unit tests and 
they failed (see previous mail) I think it could well be some problem 
with the code.

I am running OSX
Attached are the two rdf files that I ran the command with. I generated 
these files from two n3 files using cwm







18:59:59 - ~/Work/Programming/w3c/2000/10/swap
hjs@bblfish:0$ uname -a
Darwin bblfish.local 7.3.0 Darwin Kernel Version 7.3.0: Fri Mar  5 
14:22:55 PST 2004; root:xnu/xnu-517.3.15.obj~4/RELEASE_PPC  Power 
Macintosh powerpc

19:03:53 - ~/Work/Programming/w3c/2000/10/swap
hjs@bblfish:0$ python -V
Python 2.3

18:59:23 - ~/Work/Programming/w3c/2000/10/swap
hjs@bblfish:0$ ./diff.py -v -f tmp/bloged1.xml -t tmp/bloged2.xml 
Traceback (most recent call last):
   File "./diff.py", line 374, in ?
     main()
   File "./diff.py", line 357, in main
     graph = loadFiles(testFiles)
   File "./diff.py", line 318, in loadFiles
     graph = myStore.loadMany(files, openFormula=graph)
   File "/Users/hjs/Programming/w3c/2000/10/swap/myStore.py", line 159, 
in loadMany
     return _checkStore().loadMany(uris, openFormula)
   File "/Users/hjs/Programming/w3c/2000/10/swap/llyn.py", line 1150, in 
loadMany
     self.load(u, openFormula=F, remember=0)
   File "/Users/hjs/Programming/w3c/2000/10/swap/llyn.py", line 1131, in 
load
     return webAccess.load(store, uri, openFormula, asIfFrom, 
contentType, flags, why)
   File "/Users/hjs/Programming/w3c/2000/10/swap/webAccess.py", line 90, 
in load
     raise DocumentAccessError(addr, sys.exc_info() )
webAccess.DocumentAccessError: Unable to access document 
<file:/Users/hjs/Programming/w3c/2000/10/swap/tmp/bloged1.xml>, 
because:
     [Errno 2] No such file or directory: 
'/Users/hjs/Programming/w3c/2000/10/swap/tmp/bloged1.xml'



Received on Friday, 7 May 2004 13:10:29 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 19:51:59 UTC