Re: [csswg-drafts] [selectors] :drop() should not be a pseudo-function

The pattern is followed almost everywhere in CSS. I’m pretty sure programming best practices advise against functions with such a small closed set of parameters. Perhaps the WG should explicitly adopt it as a design guideline for CSS syntax. Guidelines can be broken if there are good reasons to do so. I don’t see one here.

If shortening was the only goal, some renaming would also have done, e.g.:

- `:drop`
- `:drop-target`
- `:drop-valid`
- `:drop-invalid`
- `:drop-target:drop-valid`
- `:drop-target:drop-invalid`

GitHub Notification of comment by Crissov
Please view or discuss this issue at using your GitHub account

Received on Friday, 2 February 2018 03:16:12 UTC