Re: [csswg-drafts] [css-timing] reconsider name of frames() timing function

My 2 cents:

Indeed, `frames()` is much more intuitive than `steps()`, both in terms of naming and functionality. I don’t see any issue with collisions with `requestAnimationFrame` or `@keyframes`, by that logic `requestAnimationFrame` collides with the `<frame>` tag! 

However, we can't rename `steps()`, and having two very similar functions seems worse from a usability pov. So I would vote for extending the second parameter of `steps()` to cover the current definition of `frames()`. No strong opinions about the name of that parameter, but `justify` made the most sense to me. It's unfortunate we cannot make this the default. 😢 

`frames()` is also a very animation-centric name, which could prove a problem down the road. In fact, [I've suggested]( that the entire spec needs to be renamed and reworded to be more about generic interpolation and less animation-specific.

GitHub Notification of comment by LeaVerou
Please view or discuss this issue at using your GitHub account

Received on Wednesday, 5 July 2017 22:15:23 UTC