Re: [csswg-drafts] [mediaqueries] Media Feature: "reduce motion" user setting

Not sure if it’s entirely germane, but if people think there’s a 
strong likelihood that a future user-agent might have a hard setting, 
I think it would be a much better to just have one feature and have 
the hard setting be a different value. (This is how I read @inoas's 
comment, too, but I could have misunderstood.)

I think that keeps things conceptually simpler, but, more critically, 
it allows authors to express a query for the condition "prefers 
reduced motion OR has motion turned off." With two feature names, an 
author might try and write something like this, but it wouldn’t work 
on platforms that don’t yet support both (because any query using an 
unrecognized feature evaluates to `false`):

```css
@media (motion-preference: reduce), (motion: disabled) { ... }
```

So it’d be much better to shoot for something like:

```css
@media (motion-preference: reduce), (motion-preference: no-motion) { 
... } /* or */
@media (motion: reduced), (motion: disabled) { ... }
```

-- 
GitHub Notification of comment by Mr0grog
Please view or discuss this issue at 
https://github.com/w3c/csswg-drafts/issues/442#issuecomment-265277193 
using your GitHub account

Received on Tuesday, 6 December 2016 21:25:43 UTC