[Bug 20364] New: Interface feedback

https://www.w3.org/Bugs/Public/show_bug.cgi?id=20364

            Bug ID: 20364
           Summary: Interface feedback
    Classification: Unclassified
           Product: AudioWG
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: MIDI API
          Assignee: dave.null@w3.org
          Reporter: cwilso@gmail.com
        QA Contact: public-audio@w3.org

>From Marcos Caceres (marcos@marcosc.com) 

The following is not defined correctly:

[NoInterfaceObject]
interface NavigatorMIDIAccess {
    void getMIDIAccess (NavigatorMIDIAccessSuccessCallback successCallback,
optional NavigatorMIDIAccessErrorCallback? errorCallback);

};


Should just be:

partial interface Navigator {
    void getMIDIAccess (NavigatorMIDIAccessSuccessCallback successCallback,
optional NavigatorMIDIAccessErrorCallback? errorCallback);
};





Bikeshed: NavigatorMIDIAccessSuccessCallback is a little excessive :) Just
called them "successcb" and "failcb". They are just functions without a "real"
interface, so no need to go all camel case there :)

Also, MIDIPort should not be a [NoInterfaceObject]. Either fold it into
MIDIOutput or make it into a partial interface.

Generally speaking, don't make things [NoInterfaceObject]. WebIDL says not to
do that unless its for Legacy reasons:

[[
Warning

The [NoInterfaceObject] (http://www.w3.org/TR/WebIDL/#NoInterfaceObject)
extended attribute should not be used on interfaces that are not solely used as
supplemental (http://www.w3.org/TR/WebIDL/#dfn-supplemental-interface)
interfaces, unless there are clear Web compatibility reasons for doing so.
Specification authors who wish to use this feature are strongly advised to
discuss this on the public-script-coord@w3.org
(mailto:public-script-coord@w3.org) mailing list before proceeding.
]]

Also applied to MIDIEvent.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.

Received on Wednesday, 12 December 2012 21:24:04 UTC