W3C home > Mailing lists > Public > public-aria-editors@w3.org > November 2016

Re: APG build fail

From: Michael Cooper <cooper@w3.org>
Date: Mon, 14 Nov 2016 12:55:10 -0500
To: James Nurthen <james.nurthen@oracle.com>, public-aria-editors@w3.org
Message-ID: <14d6086d-0e18-94d3-d7a5-c0ee5aa3dcd0@w3.org>
I don't think the quotes issue was the problem, it's been working with 
just the ampersand quoted for quite a while until it started breaking a 
few weeks ago - but I also don't think at the moment that your change is 
a problem either, so I'll leave it. Still think there is a problem 
loading Respec that's affecting the spec-generator. Michael


On 13/11/2016 7:48 PM, James Nurthen wrote:
>
> I think this was due to the quotes being wrong on the curl command. 
> I've changed travis.yml to add quotes around the entire url rather 
> than just the &. in the aria-practices repos.
>
> Everything seems to complete correctly now. If there are any issues 
> feel free to revert.
>
>
> On 11/8/2016 9:11 AM, Michael Cooper wrote:
>> On 08/11/2016 11:55 AM, Michiel Bijl wrote:
>>> How do you the manual build? Because I don't see the build button 
>>> Michael talked about.
>> brief instructions are at 
>> https://github.com/w3c/aria-practices/#user-content-how-to-update-document-snapshot
>>
>> I don't know who has permission to see the restart build button. I 
>> thought anybody with commit access to the repo had it, but maybe not. 
>> One of those things they don't document...
>>
>> Michael
>>>
>>> —Michiel
>>>
>>> On 8 Nov 2016, at 16:47, Matt King <a11ythinker@gmail.com 
>>> <mailto:a11ythinker@gmail.com>> wrote:
>>>
>>>> I’ve been building manually for now.
>>>>
>>>> *From:*Michael Cooper [mailto:cooper@w3.org]
>>>> *Sent:* Tuesday, November 8, 2016 6:36 AM
>>>> *To:* Michiel Bijl <michiel.list@moiety.me 
>>>> <mailto:michiel.list@moiety.me>>; Matt King <a11ythinker@gmail.com 
>>>> <mailto:a11ythinker@gmail.com>>
>>>> *Cc:* ARIA Editors <public-aria-editors@w3.org 
>>>> <mailto:public-aria-editors@w3.org>>
>>>> *Subject:* Re: APG build fail
>>>>
>>>> I believe this is related to the sporadic non-functionality of 
>>>> Respec that I've been seeing for weeks now. Shane has worked with 
>>>> the systems people on this, and they did something to make it 
>>>> happen less often, but it still happens. In particular, it seems 
>>>> that to get respec-enabled documents to display properly in some 
>>>> browsers it requires a refresh [Chrome] (in other browsers 
>>>> [Firefox] even that doesn't work and it's just random luck as to 
>>>> whether Respec works). Because the spec-generator service doesn't 
>>>> refresh, it just fails. Shane said the spec-generator doesn't use a 
>>>> browser, but it does seem to me to fail in the same frequency that 
>>>> browsers do
>>>>
>>>> I still don't know what is causing the failure - a change in 
>>>> browser security models, some subtle thing in the source of our 
>>>> documents that isn't obvious, a change to W3C anti-denial of 
>>>> service practices, some strange bug in Respec - so I haven't known 
>>>> who to file a bug report with. Shane's attempt to work with the W3C 
>>>> systems people seems to have produced some results but not resolved 
>>>> the problem; I believe they're having a hard time duplicating the 
>>>> problem even though I see it on nearly every document I work with.
>>>>
>>>> I've been thinking of trying to come up with a workaround to this, 
>>>> by including Respec as a library in our repositories rather than 
>>>> pointing to its location on the W3C server, but until I get the 
>>>> aria-common library working I won't know how to make that work. 
>>>> I've also thought of trying to install the spec generator locally 
>>>> within the build script rather than rely on the online version 
>>>> (that fails a lot in the best of circumstances), but the 
>>>> documentation is atrocious and I can't figure out how to get 
>>>> started. It's all on my todo list, and perhaps I need to escalate 
>>>> with more knowledgeable people.
>>>>
>>>> In the meantime, since the problem seems to be sporadic, you can 
>>>> always try to restart the build. For practices, go to 
>>>> https://travis-ci.org/w3c/aria-practices/ and hit "Restart build". 
>>>> I just tried this and it didn't work, but sometimes I have seen it 
>>>> work.
>>>>
>>>> Michael
>>>>
>>>> On 08/11/2016 8:32 AM, Michiel Bijl wrote:
>>>>
>>>>     Hi,
>>>>
>>>>     Ever since pull request #147
>>>>     <https://github.com/w3c/aria-practices/issues/147> was merged
>>>>     into master the build is failing again. I’m not quite sure how
>>>>     to fix this, but could somebody look at it? If you know what it
>>>>     is I’d love to learn for next time this happens.
>>>>
>>>>
>>>>     —Michiel
>>>>
>>
>
> -- 
> Regards, James
>
> Oracle <http://www.oracle.com>
> James Nurthen | Principal Engineer, Accessibility
> Phone: +1 650 506 6781 <tel:+1%20650%20506%206781> | Mobile: +1 415 
> 987 1918 <tel:+1%20415%20987%201918> | Video: james.nurthen@oracle.com 
> <sip:james.nurthen@oracle.com>
> Oracle Corporate Architecture
> 500 Oracle Parkway | Redwood Cty, CA 94065
> Green Oracle <http://www.oracle.com/commitment> Oracle is committed to 
> developing practices and products that help protect the environment
>
Received on Monday, 14 November 2016 17:55:20 UTC

This archive was generated by hypermail 2.3.1 : Monday, 14 November 2016 17:55:20 UTC