W3C home > Mailing lists > Public > ietf-http-wg@w3.org > July to September 2010

Re: Unifying & standardizing X-Moz & X-Purpose headers

From: Roy T. Fielding <fielding@gbiv.com>
Date: Thu, 23 Sep 2010 16:23:37 -0700
Cc: HTTP Working Group <ietf-http-wg@w3.org>
Message-Id: <5744C9C4-E06A-4D62-B97D-A205B6630592@gbiv.com>
To: Gavin Peters (蓋文彼德斯) <gavinp@chromium.org>
On Sep 23, 2010, at 11:56 AM, Gavin Peters (蓋文彼德斯) wrote:

> Given that http requests are already happening with these markers, and
> that there's three incompatible & inconsistant practices for
> specifying this activity,
> how should we proceed?  I think it would be best if there was one
> header for conveying purposes such as prefetch, preview, etc....
> Immediately, I think a variation on the Safari practice, and a header
> such as:
>  Purpose: preview
> or
>  Purpose: prefetch
> Is likely to best serve everybody's interest.
> Do we agree that this is a useful thing to specify, and if so, what is
> the best way to proceed if we agree?

Yes.  For example, I put in waka

    messageType  = "Q"        ; active request
                 | "q"        ; passive request
                 | "f"        ; prefetch request
                 | "P"        ; active test-probe
                 | "p"        ; passive test-probe

Which would translate into

   (default no header = active)
   Purpose: passive   (inline image, stylesheet, etc.)
   Purpose: prefetch  (what you describe for cache or preview)

I am assuming that the preview function also populates the cache
and acts as a prefetch.  If not, then you might want to distinguish
them as separate purposes.

Received on Thursday, 23 September 2010 23:24:07 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:13:48 UTC