Re: issue 85 - range unit extensions

> Right now, cache range operations are independent of content type.
> For the proposal, the name "items" seems too generic for something
> which only works with JSON (perhaps even only JSON structured in a
> particular way?).
> Unless it's understood that cache range operations on "items" must
> take into account other headers such as Content-Type.  I think that
> would be reasonable.

I certainly don't mind using a different name, if the HTTP working feels 
that's more appropriate. I just figured "items" might be applicable in 
multiple content types (applicable to content types that support a top-level 
array-like construct), but I understand that if it is felt to be too generic 
to have a real clear purpose in every situation. Maybe "array-items"?

> (Btw, one can easily imagine ranges "characters", "xpath", "xquery",
> "grep"... even "session".  I'm not sure if that's a desirable road to
> go down.  Maybe it would be very useful.)

"date" ranges is the one other unit that I have felt would be useful, but 
"items" is certainly the most valuable alternate IMO.


Received on Monday, 1 September 2008 15:54:18 UTC