On WSDL "operation"

All,

And here are some more thoughts on the naming of the "operation" element
in WSDL...


We believe that the term "operation" gives the wrong impression about
the semantics of a Web service, and has lead to much confusion and
malpractice in the developer community where WSDL portTypes (now
interfaces) have been wrongly equated to interfaces of implementing
objects. Since a Web Service sends and receives messages, we propose
that a Web service interface consists of "messageExchange" elements
rather than "operations". 

<interface>
   <messageExchange>
      <input message="..."/>
      <output message="..."/>
      <fault message="..."/>
   </messageExchange>
</interface>

Furthermore, we would ask that any language concerning "interface
inheritance" is changed to more accurately reflect that WSDL 1.2 allows
interfaces to be aggregated. This again removes any unintentional
linkage to objects and typed interfaces.

Regards,
Jim Webber
Savas Parastatidis

Received on Tuesday, 9 September 2003 07:46:22 UTC