W3C home > Mailing lists > Public > www-lib@w3.org > April to June 2002

Re: [FYI] New WIN32 Makefiles + DAV support

From: Jose Kahan <jose.kahan@w3.org>
Date: Thu, 6 Jun 2002 17:40:28 +0200
To: www-lib@w3.org
Message-ID: <20020606174028.F11805@inrialpes.fr>

Hello Richard,

Thanks for all your tips. 
On Thu, Jun 06, 2002 at 12:15:12AM +0200, Richard Atterer wrote:
> 
> > line 1134: I added an #ifndef __MINGW332. You had commented out the
> > code for all the platforms.
> 
> Yes, because as the comment says the code is useless since the
> configure script already defines u_short etc. The only purpose served
> by those defines is to cause further breakage in the future with any
> other headers which contain typedefs for u_short/u_long. <shrug>

Ok, I commented it and added it.

> > If my compile succeds, I'll commit your patch right away.
> 
> Great! I updated my CVS repository last night (June 5th, 18:00 UTC)
> and it already seemed to have been applied then.

Yes, I did it right away, as promised :)

> > After applying your patches, a file _ Library/User/Extrnals.html _
> > is not generated anymore... It seems that one of these patches broke
> > this generation, and because of that, the libwww can't be correctly
> > build... Can you help us with that? Jose is preparing a new release,
> > so we must resolve this problem quickly...
> 
> I just successfully compiled the current CVS version both under Linux
> and Windows (mingw under Cygwin). I also compiled and linked my
> application with the mingw version - everything seems to work fine. 
> (The only problem I ran into for mingw was that mingw's make seems
> broken, I had to use the Cygwin make.)

I traced this problem to a confusion with the directory path in the
Library/User/Makefile.am file. I fixed it and commited it too.
> 
> I suspect that you did not re-bootstrap everything after applying the
> patch. First, ensure you have the latest versions of libtool and
> automake. Then:
> 
>   cp /usr/share/automake/depcomp config/
>   cp /usr/share/automake/missing config/
>   libtoolize -c -f
>   perl config/winConfigure.pl
>   aclocal; autoheader; automake; autoconf
> 

Ah, I work with a debian stable box with some bits from testing. I updated
the automake, autoconf, and libtool tools from testing, but didn't
find the depcomp file. I'm using the missing file from libtool. It seems
more recent than the one from automake.

After making the call to libtoolize, I could compile without problems. I
commited the new config files and then, when I did a co on a pure debian
stable box, I got new errors saying:

	../../libtool: test =: unary operator expected.

I fixed this by invoking libtoolize -c -f. I can't tell if the error
comes from the debian package or from backwards incompatibility on those
tools. However, the libtoolize workaround solves this problem. I'll add
this info to the bootstraping page.

Maybe you have a better idea of why I had that problem.

> In particular, the config.guess/config.sub in current CVS doesn't seem
> to work properly for a i586-pc-mingw32 target. Please ensure the new
> libwww release also includes newer versions of all these auto* files!

I have those that come from Debian testing. However, those don't seem
to be the latest versions. The gnu ftp server says that the latest
autoconf is version 2.53. I prefered to leave it with v. 2.13 :)

Sometime ago, there was a site where you could download the latest
config.guess and config.sub files, but its URL must have changed. I was
unable to find it again. I may have taken those files directly from the
CVS base. 

Can you do a cvs update for libwww and see if my changes fixed your problem?
Otherwise, I'll search and update those files again.

> BTW, I'm also the maintainer for the Debian Linux libwww package.

Ah, nice to meet you! If you have other patches you'd like to apply, I can
give you a CVS write access to the repository.

Thanks again for your help Richard,

-jose
Received on Thursday, 6 June 2002 11:42:45 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 23 April 2007 18:18:42 GMT