W3C home > Mailing lists > Public > w3c-rdfcore-wg@w3.org > October 2002

Semantics was RE: weekly call for agenda items

From: Jeremy Carroll <jjc@hplb.hpl.hp.com>
Date: Fri, 25 Oct 2002 09:36:02 +0200
To: "pat hayes" <phayes@ai.uwf.edu>, "Brian McBride" <bwm@hplb.hpl.hp.com>
Cc: <w3c-rdfcore-wg@w3.org>
Message-ID: <BHEGLCKMOHGLGNOKPGHDOEHICAAA.jjc@hpl.hp.com>


> >  o semantic bugs in domain and range
>
> This is misnamed. There are currently bugs in subClassOf and
> subPropertyOf, and I will fix those bugs in the next draft of the MT.
> The question about domain and range is a genuine question, not a bug:
> we can go either way, and there are arguments in both directions, so
> we have to make a genuine decision. And since, by the way, I seem to
> be in a lone minority on this argument, I am willing to just go with
> the flow and accept the Jeremy entailment (superclasses of ranges are
> also ranges). If that will rapidly reach consensus, please let us
> rapidly reach consensus.

You are only in a minority of one in webont on a different but related
issue.
My take is that there are currently no strong advocates of the "Jeremy
entailment" (I am not one). However, this issue does interrelate with webont
issues - I suggest we:
- decide whether we prefer the Jeremy entailment or not by a straw poll
- indicate that preference to webont
- ask webont to accept this or ask us to change quickly.
(I will create the relevant web issue later today).


>
> >  o semantics of lists
>
> Let me ask that we place lists high on the agenda as we need to get
> this sorted out in order to get the MT done, and Webont needs it, and
> there are apparently some strongly held opinions about it.

As the person with the strongly held opinions I guess I should articulate a
way forward that I could support:
[[


RDF Core provide only syntax
Webont use range constraints etc to convert rdf:List into owl:List

owl:List subClassOf rdf:List
owl:unionOf rdfs:range owl:List
owl:List owl:unionOf << _:nil _:properList >> .
_:nil owl:oneOf << rdf:nil >>
_:properList is restriction on rdf:List to things
with exactly one rdf:first and exactly one rdf:rest.


There is still a need for a magic wand to be cast by Pat or Peter to address
the problem that we really want finite non-circular lists, a constraint that
is not first-order. That wand is cast in WebOnt.


]]

>
>
Received on Friday, 25 October 2002 03:36:11 EDT

This archive was generated by hypermail pre-2.1.9 : Wednesday, 3 September 2003 09:52:30 EDT