W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API naming

From: Joćo Eiras <joao.eiras@gmail.com>
Date: Thu, 25 Jan 2007 19:14:25 -0000
To: "Ian Hickson" <ian@hixie.ch>
Cc: "Web APIs WG" <public-webapi@w3.org>
Message-ID: <op.tmp42b1tjz3wb9@dragast>

Na , Ian Hickson <ian@hixie.ch> escreveu:

> On Thu, 25 Jan 2007, Anne van Kesteren wrote:
>> So the WG just discussed in a little over an hour a counter proposal to
>> the current naming[1] and came up with:
>>  * getElementBySelectors()
>>  * getElementListBySelectors()
>> I don't really like them. Supposedly I'm to edit the draft to reflect  
>> this...
> Given that this discussion was done behind closed doors, and given that
> there is certainly not consensus on this (the first reaction I saw on IRC
> to this was "wow, those names suck!")

I find these much better than all other propositions,  and I'm not lazy to  
type longer method names, if they're descriptive. So, it's a matter of  
personal opinion that "names suck".

> I think it is very disappointing to
> see the working group override the editor on this. It sets a bad  
> precedent
> in the new world of public Web spec development.
Received on Thursday, 25 January 2007 19:14:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC