W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API naming

From: Jon Ferraiolo <jferrai@us.ibm.com>
Date: Thu, 25 Jan 2007 10:38:41 -0800
To: "Anne van Kesteren" <annevk@opera.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <OF2AFC8F5C.E21528A1-ON8825726E.0065AFF6-8825726E.00666B2E@us.ibm.com>

Hi Anne,
These names are fine with me.

Jon

ps - I can certainly sympathize with you having to make an editorial change
with which you disagree. I had to do this hundreds of time during my
editorial stints in W3C committees. The worst one of all was when the SVG
working decided against my very strong arguments that the coordinate system
for SVG should have the y axis pointing down, which result in rotations
going the wrong direction versus what we all learn in school. I still have
nightmares about that one. But getting a standard out the door (with a few
warts) is better than endless argument.



                                                                           
             "Anne van                                                     
             Kesteren"                                                     
             <annevk@opera.com                                          To 
             >                         "Web API WG (public)"               
             Sent by:                  <public-webapi@w3.org>              
             public-webapi-req                                          cc 
             uest@w3.org                                                   
                                                                   Subject 
                                       Selectors API naming                
             01/25/2007 10:26                                              
             AM                                                            
                                                                           
                                                                           
                                                                           
                                                                           





So the WG just discussed in a little over an hour a counter proposal to
the current naming[1] and came up with:

  * getElementBySelectors()
  * getElementListBySelectors()

I don't really like them. Supposedly I'm to edit the draft to reflect
this...


[1]<
http://dev.w3.org/cvsweb/~checkout~/2006/webapi/selectors-api/Overview.html?content-type=text/html;%20charset=utf-8&r=1.19
>


--
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>






graycol.gif
(image/gif attachment: graycol.gif)

pic08750.gif
(image/gif attachment: pic08750.gif)

ecblank.gif
(image/gif attachment: ecblank.gif)

Received on Thursday, 25 January 2007 18:38:58 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT