W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API updates

From: Maciej Stachowiak <mjs@apple.com>
Date: Wed, 10 Jan 2007 17:50:40 -0800
Message-Id: <62B36C3A-65AD-410F-8734-76568D53460A@apple.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
To: Anne van Kesteren <annevk@opera.com>

On Jan 9, 2007, at 2:08 PM, Anne van Kesteren wrote:

> I updated the Selectors API specification today and added  
> equivalent methods for element nodes. It didn't make much sense to  
> me to postpone this.
> I resolved the naming debate by going for:
> * Document.get()
> * Document.getAll()
> * Element.get()
> * Element.getAll()
> These names are short, don't clash with autocomplete and provide a  
> superset of the functionality given by the other get* methods.


I think short names will be good for readability of DOM code, if  
these methods become as widely used as we expect. And they will do a  
lot towards making standard DOM methods competitive in conciseness  
and ease of use with "DOM Level 0" APIs.

Received on Thursday, 11 January 2007 01:51:11 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT