W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Charles McCathieNevile <chaals@opera.com>
Date: Mon, 25 Dec 2006 21:23:44 +0100
To: Martijn <martijn.martijn@gmail.com>, "Anne van Kesteren" <annevk@opera.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.tk4tlugfwxe0ny@widsith.lan>

On Sun, 24 Dec 2006 16:45:20 +0100, Martijn <martijn.martijn@gmail.com>  
wrote:

>
> On 12/24/06, Anne van Kesteren <annevk@opera.com> wrote:
>> On Sun, 24 Dec 2006 16:26:51 +0100, Martijn <martijn.martijn@gmail.com>
>> wrote:
>> > - It's too generic. Instead of matchAll, it could have been named
>> > getAll, collectAll, etc.
>>
>> I would be fine with get() and getAll() on document (and element). I 
>> agree
>> that they would make more sense.
>
> Well, my point was actually that they don't make sense, since it could
> mean anything.
> So, I would not be happy with using those names.

Yeah, my suspicion is that that would be a step in the  
much-too-generic-to-be-clear
direction that leads, down the track, to the thing that is even better  
being
called something even less clear.

cheers

Chaals

-- 
Charles McCathieNevile, Opera Software: Standards Group
hablo español - je parle français - jeg lærer norsk
chaals@opera.com Try Opera 9 now! http://opera.com
Received on Monday, 25 December 2006 20:23:57 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT