W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Martijn <martijn.martijn@gmail.com>
Date: Sun, 24 Dec 2006 16:45:20 +0100
Message-ID: <6c97b8b10612240745q6adaf0he8b1d9068030a32@mail.gmail.com>
To: "Anne van Kesteren" <annevk@opera.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>

On 12/24/06, Anne van Kesteren <annevk@opera.com> wrote:
> On Sun, 24 Dec 2006 16:26:51 +0100, Martijn <martijn.martijn@gmail.com>
> wrote:
> > - It's too generic. Instead of matchAll, it could have been named
> > getAll, collectAll, etc.
> I would be fine with get() and getAll() on document (and element). I agree
> that they would make more sense.

Well, my point was actually that they don't make sense, since it could
mean anything.
So, I would not be happy with using those names.

> > - It is inconsistent with current naming. Isn't there a need/desire
> > for the w3c to be consistent with the naming of new methods regarding
> > older specs?
> Not if the old methods effectively become obsolete. True enough, they
> return a live NodeList and so might be useful for some use cases but I
> don't think that goes for the majority if you see the usage of such
> methods on the web.

So the plan of matchAll is to make getElementById and
getElementsByTagName effectively obsolete? And that's why a different
sort of name is justified?


> Anne van Kesteren
> <http://annevankesteren.nl/>
> <http://www.opera.com/>

Martijn Wargers
Help Mozilla!
Received on Sunday, 24 December 2006 15:45:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC