W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Anne van Kesteren <annevk@opera.com>
Date: Sun, 24 Dec 2006 16:32:42 +0100
To: Martijn <martijn.martijn@gmail.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
Message-ID: <op.tk2lgsh464w2qv@id-c0020>

On Sun, 24 Dec 2006 16:26:51 +0100, Martijn <martijn.martijn@gmail.com>  
wrote:
> - It's too generic. Instead of matchAll, it could have been named
> getAll, collectAll, etc.

I would be fine with get() and getAll() on document (and element). I agree  
that they would make more sense.


> - It is inconsistent with current naming. Isn't there a need/desire
> for the w3c to be consistent with the naming of new methods regarding
> older specs?

Not if the old methods effectively become obsolete. True enough, they  
return a live NodeList and so might be useful for some use cases but I  
don't think that goes for the majority if you see the usage of such  
methods on the web.


-- 
Anne van Kesteren
<http://annevankesteren.nl/>
<http://www.opera.com/>
Received on Sunday, 24 December 2006 15:32:59 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT