W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: prov:value versus KeyValuePair

From: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
Date: Tue, 15 May 2012 16:43:02 +0100
Message-ID: <EMEW3|a2057828fc0919602541bfd36c2696feo4EGh408L.Moreau|ecs.soton.ac.uk|4FB27986.7070104@ecs.soton.ac.uk>
To: Stephan Zednik <zednis@rpi.edu>, Timothy Lebo <lebot@rpi.edu>
CC: public-prov-wg@w3.org


On 05/15/2012 04:35 PM, Stephan Zednik wrote:
> On May 15, 2012, at 9:33 AM, Timothy Lebo wrote:
>
>    
>> Stephan and WG,
>>
>> Given Luc's response about Dictionaries providing structure to Entities, can we go with pairKey and pairValue?
>>      
> I think this is the best solution forward.
>    

+1

Luc

> --Stephan
>
>    
>> Any more concerns?
>>
>> Thanks,
>> Tim
>>
>>
>>
>>      
>>>> Leaning towards Luc and Stephan, what about
>>>>
>>>> [
>>>> a prov:KeyValuePair;
>>>> prov:pairKey      "goalie";
>>>> prov:pairValue  :joe_the_tank;
>>>> ]
>>>>
>>>> I think the property should be named by the role, not its range - otherwise we'd have pairString which is odd.
>>>>          
>>> I think this goes back to my preference for prov:KeyEntityPair over prov:KeyValuePair.
>>>
>>> Why can only entities be the value in a KeyValuePair?
>>>
>>> --Stephan
>>>        
>>
>>
>>
>>      
>    

-- 
Professor Luc Moreau
Electronics and Computer Science   tel:   +44 23 8059 4487
University of Southampton          fax:   +44 23 8059 2865
Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
Received on Tuesday, 15 May 2012 15:43:45 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 15 May 2012 15:43:45 GMT