W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

[owl changed] Re: prov:value versus KeyValuePair

From: Timothy Lebo <lebot@rpi.edu>
Date: Thu, 17 May 2012 14:06:52 -0400
Cc: Stephan Zednik <zednis@rpi.edu>, public-prov-wg@w3.org
Message-Id: <C70C7BB8-495E-464B-8950-64021A1FF8F2@rpi.edu>
To: Luc Moreau <L.Moreau@ecs.soton.ac.uk>
After weeks of discussion on phone and email,

1)
prov:value has been renamed to prov:pairValue
prov:key has been renamed to prov:pairKey

http://dvcs.w3.org/hg/prov/rev/215238f50bd5


2)
prov:value was reintroduced as DM's "value" (and rdf:value)

http://dvcs.w3.org/hg/prov/rev/b5caabaf5a5b

Regards,
Tim


On May 15, 2012, at 11:43 AM, Luc Moreau wrote:

> 
> 
> On 05/15/2012 04:35 PM, Stephan Zednik wrote:
>> On May 15, 2012, at 9:33 AM, Timothy Lebo wrote:
>> 
>>   
>>> Stephan and WG,
>>> 
>>> Given Luc's response about Dictionaries providing structure to Entities, can we go with pairKey and pairValue?
>>>     
>> I think this is the best solution forward.
>>   
> 
> +1
> 
> Luc
> 
>> --Stephan
>> 
>>   
>>> Any more concerns?
>>> 
>>> Thanks,
>>> Tim
>>> 
>>> 
>>> 
>>>     
>>>>> Leaning towards Luc and Stephan, what about
>>>>> 
>>>>> [
>>>>> a prov:KeyValuePair;
>>>>> prov:pairKey      "goalie";
>>>>> prov:pairValue  :joe_the_tank;
>>>>> ]
>>>>> 
>>>>> I think the property should be named by the role, not its range - otherwise we'd have pairString which is odd.
>>>>>         
>>>> I think this goes back to my preference for prov:KeyEntityPair over prov:KeyValuePair.
>>>> 
>>>> Why can only entities be the value in a KeyValuePair?
>>>> 
>>>> --Stephan
>>>>       
>>> 
>>> 
>>> 
>>>     
>>   
> 
> -- 
> Professor Luc Moreau
> Electronics and Computer Science   tel:   +44 23 8059 4487
> University of Southampton          fax:   +44 23 8059 2865
> Southampton SO17 1BJ               email: l.moreau@ecs.soton.ac.uk
> United Kingdom                     http://www.ecs.soton.ac.uk/~lavm
> 
> 
> 
Received on Thursday, 17 May 2012 18:08:22 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 17 May 2012 18:08:25 GMT