W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: prov:value versus KeyValuePair

From: Timothy Lebo <lebot@rpi.edu>
Date: Tue, 15 May 2012 11:41:46 -0400
Cc: Luc Moreau <L.Moreau@ecs.soton.ac.uk>, public-prov-wg@w3.org
Message-Id: <C3A9C1C4-9255-4895-814C-779ADF2CC1AE@rpi.edu>
To: Stephan Zednik <zednis@rpi.edu>

On May 15, 2012, at 11:35 AM, Stephan Zednik wrote:

> 
> On May 15, 2012, at 9:33 AM, Timothy Lebo wrote:
> 
>> Stephan and WG,
>> 
>> Given Luc's response about Dictionaries providing structure to Entities, can we go with pairKey and pairValue?
> 
> I think this is the best solution forward.

Thanks, Stephan.

If I hear no other objections, I'll rename them soon so we can close out ISSUE-363

-Tim



> 
> --Stephan
> 
>> 
>> Any more concerns?
>> 
>> Thanks,
>> Tim
>> 
>> 
>> 
>>>> Leaning towards Luc and Stephan, what about 
>>>> 
>>>> [ 
>>>> a prov:KeyValuePair;
>>>> prov:pairKey      "goalie"; 
>>>> prov:pairValue  :joe_the_tank;
>>>> ]
>>>> 
>>>> I think the property should be named by the role, not its range - otherwise we'd have pairString which is odd.
>>> 
>>> I think this goes back to my preference for prov:KeyEntityPair over prov:KeyValuePair.
>>> 
>>> Why can only entities be the value in a KeyValuePair?
>>> 
>>> --Stephan
>> 
>> 
>> 
>> 
> 
> 
> 
Received on Tuesday, 15 May 2012 15:42:44 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 15 May 2012 15:42:44 GMT