W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: prov:value versus KeyValuePair

From: Stephan Zednik <zednis@rpi.edu>
Date: Tue, 15 May 2012 09:35:17 -0600
Cc: Luc Moreau <L.Moreau@ecs.soton.ac.uk>, public-prov-wg@w3.org
Message-Id: <4FC2D2BA-29D0-4A57-9BC9-43BA2E7FEA1B@rpi.edu>
To: Timothy Lebo <lebot@rpi.edu>

On May 15, 2012, at 9:33 AM, Timothy Lebo wrote:

> Stephan and WG,
> 
> Given Luc's response about Dictionaries providing structure to Entities, can we go with pairKey and pairValue?

I think this is the best solution forward.

--Stephan

> 
> Any more concerns?
> 
> Thanks,
> Tim
> 
> 
> 
>>> Leaning towards Luc and Stephan, what about 
>>> 
>>> [ 
>>> a prov:KeyValuePair;
>>> prov:pairKey      "goalie"; 
>>> prov:pairValue  :joe_the_tank;
>>> ]
>>> 
>>> I think the property should be named by the role, not its range - otherwise we'd have pairString which is odd.
>> 
>> I think this goes back to my preference for prov:KeyEntityPair over prov:KeyValuePair.
>> 
>> Why can only entities be the value in a KeyValuePair?
>> 
>> --Stephan
> 
> 
> 
> 
Received on Tuesday, 15 May 2012 15:36:41 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 15 May 2012 15:36:41 GMT