W3C home > Mailing lists > Public > public-hydra@w3.org > July 2014

RE: Call for consensus on renaming "statusCodes" to "possibleStatus" and "StatusCodeDescription" to "Status" (ISSUE-27)

From: Markus Lanthaler <markus.lanthaler@gmx.net>
Date: Mon, 21 Jul 2014 20:49:55 +0200
To: <public-hydra@w3.org>
Message-ID: <01a401cfa514$96ea7330$c4bf5990$@gmx.net>
On 17 Jul 2014 at 09:40, Ruben Verborgh wrote:
>> +1
>> I think that Ruben's suggestion makes sense. I'm just a little
>> uncertain about "possibleStatus" property. Wouldn't simply status
>> suffice?
> 
> +1 but in hindsight, but if a better alternative for "possibleStatus"
exists,
> I'd be happy to use that.
> 
> However, "status" sounds to final; it seems like a functional property.
> Non-optimal alternatives:
> - expectedStatus (too strong, also seems functional)
> - allowedStatus (it's HTTP, all statuses are allowed)
> - canHaveStatus (too clumsy)

What about potentialStatus?


--
Markus Lanthaler
@markuslanthaler
Received on Monday, 21 July 2014 18:50:33 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:29:42 UTC