W3C home > Mailing lists > Public > public-hydra@w3.org > July 2014

Re: Call for consensus on renaming "statusCodes" to "possibleStatus" and "StatusCodeDescription" to "Status" (ISSUE-27)

From: Ruben Verborgh <ruben.verborgh@ugent.be>
Date: Thu, 17 Jul 2014 09:40:26 +0200
Cc: Gregg Kellogg <gregg@greggkellogg.net>, Markus Lanthaler <markus.lanthaler@gmx.net>, "public-hydra@w3.org" <public-hydra@w3.org>
Message-Id: <507B9948-1455-4754-B721-C8622AD2B0AF@ugent.be>
To: Tomasz Pluskiewicz <tomasz@t-code.pl>
> +1
> I think that Ruben's suggestion makes sense. I'm just a little
> uncertain about "possibleStatus" property. Wouldn't simply status
> suffice?

+1 but in hindsight, but if a better alternative for "possibleStatus" exists,
I'd be happy to use that.

However, "status" sounds to final; it seems like a functional property.
Non-optimal alternatives:
- expectedStatus (too strong, also seems functional)
- allowedStatus (it's HTTP, all statuses are allowed)
- canHaveStatus (too clumsy)

Received on Thursday, 17 July 2014 07:40:59 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:29:42 UTC