W3C home > Mailing lists > Public > public-hydra@w3.org > July 2014

Re: Call for consensus on renaming "statusCodes" to "possibleStatus" and "StatusCodeDescription" to "Status" (ISSUE-27)

From: Thomas Hoppe <thomas.hoppe@n-fuse.de>
Date: Tue, 22 Jul 2014 09:11:21 +0200
Message-ID: <53CE0E99.1010706@n-fuse.de>
To: public-hydra@w3.org
I vote for possibleStatus or just status as we
could just describe in prose that the property conveys
the meaning of a potential Status.


On 07/21/2014 08:49 PM, Markus Lanthaler wrote:
> On 17 Jul 2014 at 09:40, Ruben Verborgh wrote:
>>> +1
>>> I think that Ruben's suggestion makes sense. I'm just a little
>>> uncertain about "possibleStatus" property. Wouldn't simply status
>>> suffice?
>> +1 but in hindsight, but if a better alternative for "possibleStatus"
> exists,
>> I'd be happy to use that.
>>
>> However, "status" sounds to final; it seems like a functional property.
>> Non-optimal alternatives:
>> - expectedStatus (too strong, also seems functional)
>> - allowedStatus (it's HTTP, all statuses are allowed)
>> - canHaveStatus (too clumsy)
> What about potentialStatus?
>
>
> --
> Markus Lanthaler
> @markuslanthaler
>
>
>
>
Received on Tuesday, 22 July 2014 07:11:56 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:29:42 UTC