W3C home > Mailing lists > Public > xmlschema-dev@w3.org > January 2007

RE: Regarding XML schema validation (XSD)

From: Michael Kay <mike@saxonica.com>
Date: Tue, 2 Jan 2007 09:19:27 -0000
To: "'merryla martina'" <merryla@gmail.com>, <xmlschema-dev@w3.org>
Message-ID: <006601c72e4f$1a7110a0$6401a8c0@turtle>
I'm not sure what you mean by "the Sample txlife.xsd file".
At http://acord.org/standards/life_downloads.aspx you can download "
1.zip> Life Specifications and Documentation Final 2.15.01" which contains a
set of four schema documents including one named TXLife2.15.01.xsd. The
definition of ACORD_TYPE_CODE is at line 216 of XLifeBase2.15.01.xsd, which
is reached via a chain of includes. Starting at TXLife2.15.01.xsd, the
schemas validate OK in Saxon.
Note that http://ACORD.org/Standards/Life/2  is a namespace URI. In general
you shouldn't expect to find any resource when you try to dereference a
namespace URI - it's just a distinguishing character string, not the
location of any document.
Michael Kay


From: xmlschema-dev-request@w3.org [mailto:xmlschema-dev-request@w3.org] On
Behalf Of merryla martina
Sent: 02 January 2007 05:28
To: xmlschema-dev@w3.org
Subject: Regarding XML schema validation (XSD)



I tried to perform schema validation. The code works well. But when I tried
with the Sample txlife.xsd file from http://acord.org/ I got error in
associating the namespace with the xsd i.e. in the add () method. The add ()
method returned E_FALSE.


When I referred the MSDN library, it states that 


"E_FAIL is returned if: 


.          The collection is read-only 

.          The document is not a recognized schema 

.          An error occurs when compiling the schema 

.          The ready state of the document is not 4. "


After referring MSDN library, I tried to catch the error description.


The error descriptions look like this 

Undeclared XSD type: '{  <http://ACORD.org/Standards/Life/2>
http://ACORD.org/Standards/Life/2} ACORD_TYPE_CODE'.


So I referred the txlife.xsd schema, I found that ACORD_TYPE_CODE was
referred but not defined. After that I tried to view the site
http://ACORD.org/Standards/Life/2 for the definition of 

ACORD_TYPE_CODE.I found "page not found " error.


Here I can't understand why this error description, which is highted above,
comes, as this xsd file is a standard one. 


The sample txlife.xsd file starts like this


<xsd: schema targetNamespace="  <http://ACORD.org/Standards/Life/2>
http://ACORD.org/Standards/Life/2" xmlns="http://ACORD.org/Standards/Life/2"
<http://www.w3.org/2001/XMLSchema> " elementFormDefault="unqualified"
attributeFormDefault="unqualified" version="2.9.00"> 


Received on Tuesday, 2 January 2007 09:19:39 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:15:39 UTC