Comments on type-library http://www.w3.org/2001/03/XMLSchema/TypeLibrary-nn-math.xsd

1) The correct English spelling of imaginary has an 'a' - "imaginery" is not an English word - I would like to suggest a change to make the element name consistent with the English spelling.

2) Re. the following definition:

<xs:complexType name="rationalNumber">
  <xs:sequence>
   <xs:element name="numerator" type="numeratorPart"/>
   <xs:element name="denominator" type="denominatorPart"/>
  </xs:sequence>
 </xs:complexType>
 
 <xs:simpleType name="numeratorPart">
  <xs:restriction base="xs:integer"/>
 </xs:simpleType>
 
 <xs:simpleType name="denominatorPart">
  <xs:restriction base="xs:integer"/>
 </xs:simpleType>

As part of the process of developing the XBRL specification we have encountered use cases for fractions/rational numbers where this is inadequate. One may wish to express a rational that has a very large difference in order of magnitude between the numerator and denominator for which restricting the numerator and denominator to the value space of integer is inappropriate. In addition we have felt it to be necessary to restrict the denominator to be non-zero, non-infinite. Accordingly we have developed the following fraction type definition which I submit for your consideration as a basis for an official W3C definition.

 <!-- nonZeroNonInfiniteFloat   -->
 <simpleType name="nonZeroNonInfiniteFloat">
  <annotation>
   <documentation>
As the name implies this is a float value that can not take the value ±0 or ±INF or NaN - it is used as the type for the denominator of a fractionType
  </documentation>
  </annotation>
  <union>
   <simpleType>
    <restriction base="float">
     <minExclusive value="0"/>
     <maxExclusive value="INF"/>
    </restriction>
   </simpleType>
   <simpleType>
    <restriction base="float">
     <minExclusive value="-INF"/>
     <maxExclusive value="-0"/>
    </restriction>
   </simpleType>
  </union>
 </simpleType>
 <!-- fraction   -->
 <complexType name="fractionType">
  <sequence>
   <element name="numerator" type="float"/>
   <element name="denominator" type="nonZeroNonInfiniteFloat"/>
  </sequence>
 </complexType>

Having said that it would actually be preferable from our point of view if such a type could be added to the built-in types of XML Schema and an appropriate ordering defined vis à vis values from other numeric namespaces so that all values that lie on the non-imaginary axis are mutually comparable.

With thanks

Hugh Wallis
Vice-Chair, XBRL Specification Working Group
Distinguished Software Architect
Hyperion Solutions Corporation
5925 Airport Road, Ste. 600
Mississauga, Ontario, Canada, L4V 1W1



************************************************************************

If you received this e-mail in error please delete it and notify the sender as soon as possible. The contents of this e-mail may be confidential and the unauthorized use, copying, or dissemination of it and any attachments to it, is prohibited.

Internet communications are not secure and Hyperion does not, therefore, accept legal responsibility for the contents of this message nor for any damage caused by viruses. The views expressed here do not necessarily represent those of Hyperion.

For more information about Hyperion, please visit our Web site at www.hyperion.com

Received on Wednesday, 9 April 2003 13:53:44 UTC