W3C home > Mailing lists > Public > www-ws-desc@w3.org > March 2004

RE: renaming operation/{input,output}/@messageReference

From: Liu, Kevin <kevin.liu@sap.com>
Date: Mon, 8 Mar 2004 23:34:10 +0100
Message-ID: <99CA63DD941EDC4EBA897048D9B0061DA95EAA@uspalx20a.pal.sap.corp>
To: "'Sanjiva Weerawarana'" <sanjiva@watson.ibm.com>, www-ws-desc@w3.org

No strong preference, but messageLabel does sound better.

Best Regards,

-----Original Message-----
From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org] On Behalf Of Sanjiva Weerawarana
Sent: Monday, Mar 08, 2004 11:22 AM
To: www-ws-desc@w3.org
Subject: renaming operation/{input,output}/@messageReference

We had agreed sometime ago to rename @messageReference to @label
(and the corresponding property from {message reference} to {label}.

During the name name consistification task assigned to Glen and I,
Glen suggested the name "messageLabel" instead of just plain "label."
I looked at the patterns spec too and it talks about messages with label
A etc.- so using messageLabel seems quite clean and consistified.

I've tenatively made the change to messageLabel and {message label}
and committed the draft. Take a look and let me know if this is not
acceptable. (Its a bit beyond an editorial change as the user-visible
attribute syntax is at issue .. let's try to decide via email.)

As always the latest editor's draft can be found at:
Received on Monday, 8 March 2004 17:34:55 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:39 UTC