W3C home > Mailing lists > Public > www-ws-desc@w3.org > March 2004

renaming operation/{input,output}/@messageReference

From: Sanjiva Weerawarana <sanjiva@watson.ibm.com>
Date: Tue, 9 Mar 2004 01:21:31 +0600
Message-ID: <02da01c40542$91a1b190$c8d418ac@watson.ibm.com>
To: <www-ws-desc@w3.org>

We had agreed sometime ago to rename @messageReference to @label
(and the corresponding property from {message reference} to {label}.

During the name name consistification task assigned to Glen and I,
Glen suggested the name "messageLabel" instead of just plain "label."
I looked at the patterns spec too and it talks about messages with label
A etc.- so using messageLabel seems quite clean and consistified.

I've tenatively made the change to messageLabel and {message label}
and committed the draft. Take a look and let me know if this is not
acceptable. (Its a bit beyond an editorial change as the user-visible
attribute syntax is at issue .. let's try to decide via email.)

As always the latest editor's draft can be found at:
Received on Monday, 8 March 2004 14:22:09 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:39 UTC