W3C home > Mailing lists > Public > www-ws-desc@w3.org > November 2003

PROPOSAL: SOAP binding syntax cleanup

From: Sanjiva Weerawarana <sanjiva@watson.ibm.com>
Date: Sun, 2 Nov 2003 22:50:26 +0600
Message-ID: <019501c3a1fb$b32fbfa0$10266a20@lankabook2>
To: <www-ws-desc@w3.org>

I'm editing the binding stuff:

(1) Rename wsoap:operation to wsoap:action
        Currently we have 
            <wsoap:operation soapAction="uri"?/>
        and of course its optional (meaningless when @soapAction
        is missing. This used to have @style as well, but that's
        now gone. So, its new purpose is to specify per-operation
        SOAPAction values - hence I propose we replace this
            <wsoap:action uri="uri"/>

(2) Drop wsoap:headerFault
        I believe there's an issue for this already. I can't
        figure out what headerFault means .. hence the proposal
        to drop it :-).

Received on Monday, 3 November 2003 06:14:16 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:36 UTC