W3C home > Mailing lists > Public > www-ws-desc@w3.org > February 2003

Re: HTML version of operation name proposal

From: Jacek Kopecky <jacek@systinet.com>
Date: 06 Feb 2003 18:54:13 +0100
To: Sanjiva Weerawarana <sanjiva@watson.ibm.com>
Cc: Roberto Chinnici <roberto.chinnici@sun.com>, WS Description WG <www-ws-desc@w3.org>
Message-Id: <1044554053.20919.20.camel@krava.in.idoox.com>

On Thu, 2003-02-06 at 06:04, Sanjiva Weerawarana wrote:
> > Yes, if you follow the best practice you won't ever be in trouble.
> In summary, you are saying that the right thing to do is use global
> operation names (where the operation name is now a QName).
> I thought that's exactly the problem we were trying to solve?

I believe what we're trying to accomplish is disambiguating between
operations in the binding. In WSDL 1.1, input and output names in a
portType's operations had to be unique as they served as the
disambiguators necessary for operation bindings. 

In 1.2 with inheritance, we have something like three options:

1) refer to operations using the tuple {portType QName, operation name}
   (a crazy version of this is below (*))
2) refer to operations using their QNames (the current proposal)
3) reintroduce now globally unique input and output names

The first option is perfect, if a little complex; the second has
problems Sanjiva's been pointing out and it is about as complex as the
first one; the third just moves the problem from operation names to
input and output names.

I wasn't at the F2F, has the first option been discussed there? I
believe it was proposed in the past few days that the bindings refer to
operations using two attributes - name and (optional) namespace. Making
these attributes name and (optional) portType QName would be about as
intrusive as the former, and it might remove (at least some of)
Sanjiva's objections.

Have I missed something?

                   Jacek Kopecky

                   Senior Architect, Systinet Corporation

(*) why don't we refer to operations with a QName, the local part being
the name of the operation, the namespace name being the component
designator (R120) URI for the portType? 8-) 

Just joking, really, as it wouldn't go along with my vision on how R120
should be satisfied.
Received on Thursday, 6 February 2003 12:54:21 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:28 UTC