Re: ISSUE:3.4 daml:unambiguousProperty

i vote for FunctionalProperty and inverseFunctionalProperty
mostly because i can not come up with any other terms that are clear and at
least these are clear.
I agree that they are math terms but any terms we use will not be clear to
some users and at least these are unambiguous.


Christopher Welty wrote:

> All,
> At the telecon today (July 11), I was made owner of this issue.
> What we discussed in the telecon was actually issue 4.1 - that "unique"
> and "unambiguous" are bad names (and what they mean).
> Issue 3.4 is that daml:unambiguousProperty is not included in OWL.
> There appears to have been consensus to resolve this issue as follows:
> Although UnambiguousProperty can be expressed in a variety of ways by
> combining other language features (one way is to use UniqueProperty and
> inverse), it is a useful feature and should be in OWL, most likely under a
> different name - see issue 4.1.
> -Chris
> Dr. Christopher A. Welty, Knowledge Structures Group
> IBM T.J. Watson Research Center
> PO Box 704, Yorktown Heights, NY 10598, USA
> +1-914-784-7055 Fax: +1-914-784-6078

 Deborah L. McGuinness
 Knowledge Systems Laboratory
 Gates Computer Science Building, 2A Room 241
 Stanford University, Stanford, CA 94305-9020
 (voice) 650 723 9770    (stanford fax) 650 725 5850   (computer fax)  801 705

Received on Thursday, 18 July 2002 13:09:29 UTC