RE: Slowness on local install, just with some URLs

Have you checked it can find a local copy of the DTDs? If it can't find them, I think it falls back to downloading DTDs from  (which would result in validation working, but being very slow)

Best Regards
Mark Rogers -<>
PowerMapper Software Ltd -<>
Registered in Scotland No 362274 Quartermile 2 Edinburgh EH3 9GL

From: Jon Cram []
Sent: 02 November 2012 08:31
Subject: Re: Slowness on local install, just with some URLs

I'm seeing the same on a two local installs of the validator.

On Ubuntu Desktop 12.10, both 64bit (my main machine) and 32 bit (a CI server), validation takes a long, long time (longer than a minute). On both machines I can retrieve the page markup with curl very quickly, there's no network issue. The happens when validating by direct input, so it's not a problem with retrieving the page markup through the validator.

On Ubuntu Server 12.04 on a remotely-hosted dedicated server I'm not getting the issue and the page validates just as quickly as it does at

I tried playing around with the doctype. Only HTML5 documents validate quickly and this is explained by the fact that HTML5 validation is deferred to the validator and hence does not use the w3c validator.

With doctypes that the w3c validator handles and even for simple documents (just an empty head and body wrapped in an html element), validation takes a very, very long time.

I have no idea why. But I can at least confirm that I'm seeing similar issues.

On 01/11/12 21:39, Jaime Iniesta wrote:
Hi, I'm having a weird issue with my local installations of the 1.3 validator.

I'm validating this URL:

If I validate it on it just takes 2 seconds to respond, but when I do it on my local installation, it takes about a minute.

Other URLs are fine, but all within this site are super slow. It does not seem a connectivity issue, as I can browse this site fine, ping, etc.

It does not happen on my local installation of<>.

I've tried on 3 different servers, with ubuntu 32 bits and 64 bits, and different locations (a dedicated server and a pair of virtual boxes on my machine).

I can't find any error on the Apache logs, is there any other log to check? Please notice that the validation goes OK, it returns 7 HTML errors, it's just slow.

Can anyone with a local installation of the validator verify this?

How can I investigate / solve this?



Received on Saturday, 3 November 2012 21:33:47 UTC