Re: New validator install says everything invalid (Was: This page is not Valid !)

Ville Skyttä wrote:
> On Mon, 2004-06-28 at 20:22, Nguyen, Long P (Mission Systems) wrote:
>>I was able to force the installation of the OpenSP-1.5
> Forcing the installation is probably a bad idea and may break your
> system in various ways, but anyway...
>> and I tried to use the Validator again and is still getting the 'This
>>page is not Valid !'

on Redhat-9 I've installed OpenSP-1.5 and I then try this:

cat test.html | /usr/local/bin/onsgmls -c 
/home/apache/htdocs/validator/sgml-lib/xml.soc -E0 -R -wvalid 
-wnon-sgml-char-ref -wno-duplicate -wxml

and I get:

/usr/local/bin/onsgmls:E: cannot find 
"/home/apache/htdocs/validator/sgml-lib/xml.soc"; tried
/usr/local/bin/onsgmls:<OSFD>0:3:83:E: URL not supported by this version
/usr/local/bin/onsgmls:<OSFD>0:3:83:E: DTD did not contain element 
declaration for document type name

and another 25 or so lines of similar errors...

Yes, the file at /home/apache/htdocs/validator/sgml-lib/xml.soc exists, 
and it's readable. I've tried many variations on this command, and I've 
tried compiling OpenSP-1.5 with gcc 3.2.3 and with gcc 2.96 and I'm 
still stuck.

I've done the  OpenSP-1.5 install before on Redhat-7 with no problem at 
all, which makes this even more frustrating!

> Are you sure that validator is using the onsgmls from the opensp package
> you installed?  Look for onsgmls in the output of "rpm -qlp opensp", and
> make sure "SGML Parser" in your validator.conf points to it.
> To verify the OpenSP/onsgmls version, do for example this:
>   /path/to/your/onsgmls --version < /dev/null
> Also, in order to work with the validator, OpenSP 1.5/onsgmls must be
> compiled with XML messages _off_.

And what parameters would be passed in to compile it with XML messages off?



Received on Monday, 28 June 2004 15:47:08 UTC