W3C home > Mailing lists > Public > www-validator@w3.org > February 2003

Installing the validator on OS X

From: Chris Casciano <chris@placenamehere.com>
Date: Fri, 28 Feb 2003 01:47:44 -0500
To: www-validator@w3.org
Message-id: <BA847040.49E0B%chris@placenamehere.com>

A conversation arose in another forum[1] regarding offline validation,
validation of content behind firewalls, yadda yadda yadda. As a result of
that conversation I am in the process of attempting to install the W3C
validator on my powerbook running OS X. Karl Dubost suggested I post my
comments on the process here so their on the record if you plan on creating
some docs in the future. (ulterior motive - its not working yet - so I'm
looking for some help too)

I. What I'm after (feel free to forward to QA if that's a more appropriate
forum for this portion)

My needs as a web developer are two fold:
- Be able to validate documents on my local dev server
- Be able to validate an entire site (either in dev or production)
- Be able to automate either task as much as possible so it becomes part of
my workflow.

Not wanting to start from scratch I've looked at two existing validators  -
the W3C validator & the HTML Help offline browser[2] - neither of which have
much documentation on attempts to install on OS X.

At this point I've gotten the HTML Help validator installed and running[3]
and that will probably serve my own needs better in the long run, but I had
some time to spare tonight so I wanted to give the W3C validator a go too.

I downloaded the source from the W3C site this evening at started at it.

II. W3C Validator Installation Comments

Onto the stuff that's germane to this list and a rundown of what I did to
get the validator up and running (well... as running as it is... See below)
on OS X 10.2.4

Warning: While I have fink installed I try to avoid using it as much as
possible in the sometimes futile interest of keeping track of what's
installed where. For this reason the process I went through is all over the
map and probably doesn't lend itself to be seen as a tutorial.

Warning 2: I'm not much of a C/C++ programmer so when builds go wrong and
the problem isn't obvious (like a path problem or a missing lib) I tend to
look for another was instead of attempting to fix the problem

So, onto my notes of my saga thus far:

* PERL: of the currently listed required modules only Text::Iconv gave me
problems when installing via the the cpan shell. There were a number of
other modules required by check that I know aren't stock on OS X. Some I had
installed already, all of the required modules that were unlisted installed
fine via the cpan shell.

Getting Text::Iconv installed - The problem I ran into is that Text::Iconv
requires libiconv and it could not find it. Although the following page
describes the problem & solution the solution didn't work for me:

Finding no other potential solutions and wanting to move on I eventually
installed it via fink.

* PARSER - (note: as a result of getting the HTMLHelp Validator up and
running I already have OpenJade installed via fink.) Initial attempts to
build OpenSP-1.5 from source failed. It is available via fink, but in my
dist (0.51) its only in unstable so to get it I had to copy its the
appropriate files into /sw/fink/dists/local/main/finkinfo as described here:

* WEB FILES - My goal was to install the web files (current source tar ball)
on a locally running virtual server[4].

- I grabbed the files from the uncompressed tar ball and dropped them where
I wanted them - Htdocs in the virtual server's doc root and cgi-bin in its
cgi-bin dir and config in /etc/w3c/. This meant a few changes to the the
related html docs who wanted check in the doc root.

- the fink dist of Text::Iconv is outside of my perl include path so the
first line of check changed to:
#!/usr/bin/perl -TI /sw/lib/perl5

- the file validator.conf file wasn't included in the tar dist... Grabbed it
from cvs, made the needed changes (pointing at the parser in /sw/bin being
one) & tossed it in /etc/w3c

- at this point check picked up the config file, but wasn't parsing it
properly tossing up an error for a uninitialized value for the sgml parser.
Investigation (i.e. cvs) showed the config format was totally rewritten &
migrated to Config::General so my files were out of sync (no surprise)

- switched site to cvs version. Redid some html changes. Got the templates
working. Template location is hard coded in check and I moved em so had to
change that.

This is where I have to leave it for a few days. At this point I've managed
to get all the dependencies installed and running (properly I think).

- /cgi-bin/check is running without errors
- its grabbing remote files just fine
- its picking up doctype & char encodings accurately
- source, parse tree & outlines all seem to work properly

BUT... Every document I run through the validator comes back with "This page
is not Valid !" yet no messages are given in the "below are the results"
section... This is the case with both valid and invalid docs.

I'd like to track down the problem in the script, but can't get to it
tonight and wont be able to look at this again until some time next week. So
if anyone knows what to look at or change to get this going, or knows where
I went astray please speak up. If not sit back and wait for my follow up
email in a week or so.

[1] http://www.webdesign-l/
[2] http://www.htmlhelp.com/tools/validator/offline/
[3] If you care to know, I couldn't get lq-nsgmls to build but I was able to
replace it with OpenJade with minor adjustments to their script.
[4] normal apache virtual setting w/ local dns resolution setup via NetInfo
[ Chris Casciano ]  [ chris@placenamehere.com ]
[ see things  @  http://www.placenamehere.com ]
[ read words   @   http://www.chunkysoup.net/ ]
[ buy prints @ http://placenamehere.com/store ]
Received on Friday, 28 February 2003 01:47:27 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:58:32 UTC