bug in validator?

Using Konqueror 2.11, if I type in the following URL:


I get a 'valid xhtml 1.0 strict' reply (Konqueror escapes the :// for me).
However, if I type in just:


and fill in the 'address' box with:


I get the following error:


I was not able to extract a character encoding labeling from any of the
valid sources for such information. Without encoding information it is
impossible to validate the document. The sources I tried are:

 - The HTTP Content-Type field.
 - The XML Declaration.
 - The HTML "META" element.

And I even tried to autodetect it using the algorithm defined in Appendix
F of the XML 1.0 Recommendation.

Since none of these sources yielded any usable information, I will not be
able to validate this document. Sorry. Please make sure you specify the
character encoding in use.

Note that the filename is blank. The problem appears to be that the blank
'local file' box is taking precedence over the filled-in 'address' box.
This caused me considerable confusion. I have used the validator many
times and have never encountered this problem before. Has there been a
recent change? Is this the browser's fault?

Many thanks for an otherwise excellent service.


Received on Monday, 2 December 2002 22:29:55 UTC