Renaming 'filter' member of CSSStyleDeclaration

According to Webkit people (whom I have no reason to doubt), exposing
'filter' as a member of CSSStyleDeclaration in browsers is perilous because
many Web sites do
  if (typeof( == 'string') { ... set opacity using IE's
DirectX filters }
  else { ... set opacity using standard CSS 'opacity' ... }

They've worked around it by making 'filter' undetectable with magic JS hacks
similar to what multiple browsers do with "document.all". But a much simpler
solution is to name the CSSStyleDeclaration member instead, say 'svgFilter'.
How do people feel about that? I'm not sure if any spec needs to be changed
since apparently the names of the CSSStyleDeclaration SVG members aren't
actually in any spec...

"He was pierced for our transgressions, he was crushed for our iniquities;
the punishment that brought us peace was upon him, and by his wounds we are
healed. We all, like sheep, have gone astray, each of us has turned to his
own way; and the LORD has laid on him the iniquity of us all." [Isaiah

Received on Sunday, 18 October 2009 21:18:12 UTC