Re: SVG12: getPresentation* naming

* Dean Jackson wrote:
>>   In the
>> proposed getPresentation* methods are poorly named. The names are much
>> too long and inconsistent with SVG 1.1 where getPresentationAttribute
>> behave very different from the proposed methods, and with SVGAnimated*
>> interfaces which have a animVal attribute rather than presVal. Please
>> change the names of these operations to something much shorter and more
>> consistent with SVG 1.1. Possible naming would be getAnim* but that de-
>> pends on what value these operations return in SVG "Full" as I wrote in
>> another comment.
>We discussed this and decided to keep the current names. We prefer
>descriptive names over shorter, less clear names. Also, the animVal
>attribute has caused a lot of confusion over the past few years.

I strongly object to this response. First, SVG 1.1 has many abbreviated
names so this "consistency" argument is unsound. Second, the Working
Group failed to address my concern that the naming is misleading. Third,
the Working Group failed to address my concern that the methods are too
underspecified to name them properly, substantive review comments like

have been ignored by the Working Group. And last but not least I would
like to point out that the Working Group could update specifications
if certain features cause a lot of confusion, or maintain educational
material like FAQs that remove such confusion.

Once all issues on trait access have been formally addressed I will
reconsider my position or express more clearly why I find this naming
Björn Höhrmann · ·
Weinh. Str. 22 · Telefon: +49(0)621/4309674 ·
68309 Mannheim · PGP Pub. KeyID: 0xA4357E78 · 

Received on Saturday, 21 May 2005 23:17:47 UTC